in

MetaMask / Ledger Nano S connection. Ethereum Balance showing 0

I’m trying to connect my Metamask to my Ledger hardware wallet. Hardware wallet has 2.0.0 firmware and Chrome is 91.0.x

Metamask connects via Ledger Live successfully but Metamask displays 0 balance. Etherscan for the address, clicking from MetaMask shows the address as having the correct amount of Ethereum in it, (Strangely there is only a single transaction in the activity section of Metamask, There are many older transactions on the wallet but only the recent one is showing)

I’d like to avoid transferring the Eth to a different Metamask wallet if possible. I’ve tried disconnecting and reconnecting that hardware wallet with Metamask, no luck. This ledger nano s is from ~2017ish timeframe, so not sure if that may have something to do with it?

Any ideas?

What do you think?

10 Points
Upvote Downvote

Leave a Reply

Your email address will not be published. Required fields are marked *

GIPHY App Key not set. Please check settings

One Comment

  1. > This ledger nano s is from ~2017ish timeframe, so not sure if that may have something to do with it?

    When you connect MetaMask to your ledger, make sure to select “legacy / MEW derivation path”, not “Ledger Live path”. Because at the time, the Ledger Live derivation path was not used. If you select the correct derivation path in MetaMask, then you should see your correct ledger ETH account address in the list.

Uniswap v3: Concentrated Liquidity and Capital Efficiency Coming This Week

/r/Monero Weekly Discussion – May 22, 2021 – Use this thread for general chatter, basic questions, and if you’re new to Monero